Board indexPortal
Last visit was: It is currently 17. Jul 2019 19:16


All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 18 posts ] Go to page  Previous  1, 2
FollowersFollowers: 0
BookmarksBookmarks: 0
Views: 2212

AuthorMessage
 Post subject: Re: rol-jal-bim112
PostPosted: 3. Jun 2016 10:56 

Joined: 06.2015
Posts: 50
Gender: None specified
Hendrik wrote:
Your lpcxpresso installation comes with a tool to convert the binary files. The magic command is

arm-none-eabi-objcopy -O ihex rol-jal-bim112.axf rol-jal-bim112.hex

The arm-none-eabi-objcopy should be somewhere in /path/to/lcpxpresso/lpcxpresso/tools/bin/. Also have a look at http://support.code-red-tech.com/CodeRe ... putFormats. If you have any trouble with it, ask again. I can do the conversion for you, but not before tonight.


Yes, I tried it as well this way getting a hex downloadable on uC.
No way! the problem remains, after the failure of the PA in the download starts flashing IO2 (??).
This makes me think that my hex is correct (I had the same problem), then, given that, for other people this firmware works and not to me, open up different scenarios:

1) I'm using a vd incorrect ETS file (I use MDT_KP_Jalousieaktor_V28.knxprod but I tried other)

2) The firmware uses a watchdog and Magicflash not allow me to set it (there)

3) I use a 12 MHz crystal while the firmware using an oscillator.

I do not know what else to think.

For the record, only OUT8-BCU1 I work, nothing else. (Bah?)

Anyway, your hex is well appreciated. Who knows!

paschal


Top
Offline Profile  
 
 Post subject: Re: rol-jal-bim112
PostPosted: 3. Jun 2016 11:16 

Joined: 08.2015
Posts: 161
Location: Heidelberg
Gender: Male
1) I'm using the online catalog in the ETS. As application program I've chosen the one for JAL-0410.01, 4TE, 230VAC, 10A, version 2.8.

2) There is no watchdog I know of.

3) My 4TE controller also has a crystal. No need to change anything for crystal vs oscillator for the LPC1115. The firmware doesn't know about it.

But there are other options. Like a bug in the bim112 part of the lib that causes some timing-sensitive trouble. Can you run the bus monitor when assigning the PA? If after programming the PA you disconnect the device from the bus and reconnect, do you see the PA (i.e. does it get written into the eeprom)? If you disconnet and reconnect, then check for "devices in programming mode" in the ETS, does it appear?


Top
Offline Profile  
 
 Post subject: Re: rol-jal-bim112
PostPosted: 3. Jun 2016 12:30 

Joined: 06.2015
Posts: 50
Gender: None specified
Hendrik wrote:
1) I'm using the online catalog in the ETS. As application program I've chosen the one for JAL-0410.01, 4TE, 230VAC, 10A, version 2.8.

2) There is no watchdog I know of.

3) My 4TE controller also has a crystal. No need to change anything for crystal vs oscillator for the LPC1115. The firmware doesn't know about it.

But there are other options. Like a bug in the bim112 part of the lib that causes some timing-sensitive trouble. Can you run the bus monitor when assigning the PA? If after programming the PA you disconnect the device from the bus and reconnect, do you see the PA (i.e. does it get written into the eeprom)? If you disconnet and reconnect, then check for "devices in programming mode" in the ETS, does it appear?




I managed to transfer PA and application!

Now I try the operation.


Top
Offline Profile  
 
 Post subject: Re: rol-jal-bim112
PostPosted: 3. Jun 2016 13:21 

Joined: 06.2015
Posts: 50
Gender: None specified
It seems to work well.
Infinite thanks Endrik, have a dinner paid if steps to Salerno.
paschal


Top
Offline Profile  
 
 Post subject: Re: rol-jal-bim112
PostPosted: 3. Jun 2016 13:27 

Joined: 08.2015
Posts: 161
Location: Heidelberg
Gender: Male
So did you change anything? Or did you simply convert my .axf to .hex and it worked?


Top
Offline Profile  
 
 Post subject: Re: rol-jal-bim112
PostPosted: 3. Jun 2016 13:35 

Joined: 06.2015
Posts: 50
Gender: None specified
by the time I converted your file.
Try 'then convert my. (I followed your steps but initially I did not understand that I had to use the "arm-none-eabi-objcopy" in DOS, I did it directly LPCExpresso.

thanks again.


Top
Offline Profile  
 
 Post subject: Re: rol-jal-bim112
PostPosted: 4. Jun 2016 08:55 

Joined: 06.2015
Posts: 50
Gender: None specified
Hendrik wrote:
So did you change anything? Or did you simply convert my .axf to .hex and it worked?

Good morning

I confirm the operation of my Hex (evidently it was just a problem with the conversion from AXF -> HEX).

Out of curiosity, do you work the PWM? why not me !. Probably 'it disabled. But it is essential. Who knows where you turn !.

Good day
paschal


Top
Offline Profile  
 
 Post subject: Re: rol-jal-bim112
PostPosted: 4. Jun 2016 10:34 

Joined: 08.2015
Posts: 161
Location: Heidelberg
Gender: Male
I haven't looked into this, yet, so I don't know if PWM is active or not. I also had a problem with one configuration in which a STEP command resulted in an endless move. So there is still some debugging to be done, but simple setups seem to work.


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page  Previous  1, 2

All times are UTC + 1 hour [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group | Theme created StylerBB.net
phpBB3 free Forum by UserBoard.org | All Rights Reserved.
» Contact & Abuse Support-Forum Gooof Webdesign free forum Dein Forumo Forum web tracker