ForumPortal
Dein letzter Besuch: Aktuelle Zeit: 18. Jul 2018 22:24


Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 6 Beiträge ] 
AbonnentenAbonnenten: 0
LesezeichenLesezeichen: 0
Zugriffe: 370

AutorNachricht
 Betreff des Beitrags: TS-ARM testen
BeitragVerfasst: 30. Jul 2017 21:16 

Registriert: 07.2017
Beiträge: 8
Geschlecht: nicht angegeben
Guten Abend!

Ich habe mal ein TS-ARM Board aufgebaut. Hierzu habe ich noch ein paar Fragen:

1. Wird der externe Oszillator zwingend benötigt ?

2. Welche Frequenz sollte er haben?

3. Hat jemand eine 8in oder 16in Version in Betrieb und könnte mal das .hex zur Verfügung stellen ?

Ich habe die PCB-Version aus dem Shop aufgebaut, aktuell keinen externen Osc.

Folgende Software habe ich kompiliert und geflasht:
software-arm-incubation-master.zip\software-arm-incubation-master\sensors\binary-inputs\in8-bcu1

software-arm-incubation-master.zip\software-arm-incubation-master\sensors\binary-inputs\in16-bim112

Flashen des 1115 funktioniert.

Die Programmier LED leuchtet nur, so lange ich den taster betätige. Ich vermute diese sollte dauerhaft aktiv bleiben, bis die Adresse vergeben wurde.

In ETS5 kann ich keine Adresse vergeben, als Gerät habe ich Jung 2118 versucht.

Viele Grüße


Nach oben
Offline Profil  
 
 Betreff des Beitrags: Re: TS-ARM testen
BeitragVerfasst: 30. Jul 2017 23:43 

Registriert: 08.2015
Beiträge: 83
Wohnort: Paderborn
Geschlecht: männlich
Du hast momentan weder Quarz noch Oszillator auf dem Board? Dann hat der ARM keinen Takt und läuft nicht... Wie du richtig vermutest ist die einfachste Kontrolle, ob der Mikrocontroller im Groben und Ganzen läuft, der Prog-Taster: Nach dem Drücken muss die Prog-LED an bleiben, nach einem weiteren Druck auf den Taster wieder aus gehen.
Wenn sie nur während des eigentlichen Tastendrucks an ist, läuft der ARM nicht (oder halt ein vollkommen falsches Programm).

12 MHz sollte der Oszillator haben.


Nach oben
Offline Profil  
 
 Betreff des Beitrags: Re: TS-ARM testen
BeitragVerfasst: 31. Jul 2017 08:20 

Registriert: 07.2017
Beiträge: 8
Geschlecht: nicht angegeben
Hallo,
danke für die schnelle Antwort.

Hast du einen TS-ARM mit 12 MHZ Oszillator stabil in Betrieb?

Ist es nicht besser einen zu nehmen, dessen Frequenz durch ganzzahliges Teilen die Baudrate, bzw die 16-fache Baudrate ergibt (z.b. 12,288)? Oder spielt das bei einem so langsamen Bus keine Rolle?

Viele Grüße


Nach oben
Offline Profil  
 
 Betreff des Beitrags: Re: TS-ARM testen
BeitragVerfasst: 31. Jul 2017 20:36 

Registriert: 08.2015
Beiträge: 83
Wohnort: Paderborn
Geschlecht: männlich
Natürlich klappt das mit den 12 MHz, die gesamte Ansteuerung ist für diese Frequenz ausgelegt. Ist aber nicht auf meinem Mist gewachsen, also kann ich nur sagen: 9600 Baud * 1250 = 12 MHz. Der Hardware-Uart wird meines Wissens nach eh nicht benutzt, also reicht der ganzzahlige Teiler vollkommen aus.


Nach oben
Offline Profil  
 
 Betreff des Beitrags: Re: TS-ARM testen
BeitragVerfasst: 1. Aug 2017 10:21 

Registriert: 07.2017
Beiträge: 17
Geschlecht: nicht angegeben
Erst einmal ein Lob, Top Projekt weiter so ….

Ich muss jetzt auch mal nachfragen, da ich den Durchblick völlig verloren habe …. :oops:
Klar beim Quarz müssen die beiden 18pF Kondensatoren eingesetzt werden.

Wenn bei ARM der XO32 12.0Mhz mit einer Lastkapazität von 15pF eingesetzt wird, sind dann die beiden Kondensatoren 100p und 220p Plicht?
Ich vermisse die in dem Warenkorb „4TE Controller ARM LPC1115“, oder kann der 100p überbrückt und der 220p raus?
Aber genau das war die Änderung zur von 1.00 auf 1.01.. :roll:
Vielleicht kann mich jemand erleuchten… :(


Nach oben
Offline Profil  
 
 Betreff des Beitrags: Re: TS-ARM testen
BeitragVerfasst: 1. Aug 2017 21:34 

Registriert: 08.2015
Beiträge: 83
Wohnort: Paderborn
Geschlecht: männlich
Der Hintergrund für die Kondensatoren im Zusammenhang mit dem Oszillator ist ein anderer: Der LPC1115 verträgt an seinem XTALIN-Pin keine 3,3V. Also muss ein Spannungsteiler her. In diesem Fall wird der Spannungsteiler aus Kondensatoren gebildet. Das ist die von NXP empfohlene Vorgehensweise.
Du bestückst also den 100pF und 220pF Kondensator, die beiden kleineren 18pF Kondensatoren jedoch nicht.

Vermutlich ist der Warenkorb schlicht noch nicht aktualisiert worden.


Nach oben
Offline Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 6 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
cron
Powered by phpBB® Forum Software © phpBB Group | Theme created StylerBB.net
phpBB3 Forum von phpBB8.de
» Kontakt & Rechtliches Support / Hilfe Forum Gooof Webdesign Kostenloses Forum Dein Forumo Forum web tracker